Blogalia. Un web para todos

Inicio > Historias > Blogatex: Editor de Blogalia para Linux

Blogatex: Editor de Blogalia para Linux


Buena parte de los usuarios activos de Blogalia usan w.bloggar para editar sus notas. Para Linux no hay muchos programas similares (Exaro, Blognix y están abandonados). Para remediar la situación, Gabriel Rodríguez (Chewie) y yo hemos programado una utilidad que se puede descargar en el repositorio de proyectos libres de Blogalia en SourceForge.

Para usar esta herramienta, que de momento hemos llamado Blogatex, hay que instalar Python 2.2, Qt 3.0, PyQt 3.5 y sip 3.5. Si alguien se anima, nos gustaría empaquetarlo en RPM y DEB.

De momento es una versión preliminar que solo funciona para Blogalia. Hace uso del MetaWeblog API y Blogger API, y en un futuro publicaremos una versión sin extensiones específicas (y quizás otra versión para las extensiones de Movable Type. Y ojo: esto es software en versión alfa ;)

Comentarios, sugerencias y demás, son bienvenidos.

| 2003-05-15 23:06 | rvr | 24 Comentarios


Referencias (TrackBacks)

URL de trackback de esta historia http://desarrollo.blogalia.com//trackbacks/8029

Comentarios

1
De: JJ Fecha: 2003-05-16 00:23

Me da un errorcillo:
[jmerelo@tresmellizas blogatex-0.1]$ Traceback (most recent call last):
File "./blogatex.py", line 272, in ?
main(sys.argv)
File "./blogatex.py", line 265, in main
win = BlogatexWindow()
File "./blogatex.py", line 157, in __init__
self.usuario = self.conf.dicConf.defaults()['usuario']
AttributeError: 'dict' object has no attribute 'defaults'
Mutex destroy failure: Dispositivo o recurso ocupado

Da la impresión de que hay que configurarlo. Le echaré un vistazo.



2
De: fernand0 Fecha: 2003-05-16 00:25

Muy bonito!



3
De: JJ Fecha: 2003-05-16 00:26

Parece que hace falta un fichero conf.txt, pero no sé el formato.



4
De: JJ Fecha: 2003-05-16 00:28

fernand0: y cómo funciona? Ejecutando blogatex.py, no?



5
De: Chewie Fecha: 2003-05-16 00:45

JJ: El formato de conf.txt es:

[DEFAULT]
clave = tuClave
usuario = tuUsuario



6
De: JJ Fecha: 2003-05-16 00:50

Va fenomenal!
Quizás sería cuestión de que lo pusiérais en el README, o incluyérais un fichero configuración de ejemplo.



7
De: fernand0 Fecha: 2003-05-16 01:50

JJ: hago mi afirmación basándome en el dibujo. Estos días no tengo tiempo para probar cosas de estas ;)



8
De: rvr Fecha: 2003-05-16 08:51

Vaya, creí subir esta tarde al FTP una actualización del tgz donde estaba el conf.txt. Hay un README, pero no explica como ejecutarlo... en el CVS encontrarás la última versión :)



9
De: Epaminondas Pantulis Fecha: 2003-05-16 17:33

Me atrevería a intentar echarlo a andar bajo Windows, pero ¿está disponible la librería Qt para Windows? En tiempos no, no sé si la cosa ha cambiado mucho.



10
De: rvr Fecha: 2003-05-16 21:18

Me temo que solo la versión 2.3 es gratuita para uso en progranas libres windoseros, Epaminondas... Lo que estaba pensando es utilizar wxPython o Gtk+ 2.0, que sí están en Windows.



11
De: teo Fecha: 2003-05-18 06:02

Hey!!! Muy bueno, si señor.

Gracias mil, en cuanto pueda hago el deb :)



12
De: teo Fecha: 2003-05-18 07:13

Hey!!! Muy bueno, si señor.

Gracias mil, en cuanto pueda hago el deb :)



13
De: El GNUdista Fecha: 2003-05-18 17:19

A mi me tira el siguiente error:
----
File "./blogatex.py", line 11, in ?
from qt import *
File "/usr/lib/python2.2/site-packages/qt.py", line 39, in ?
import libqtc
ImportError: /usr/lib/python2.2/site-packages/libqtcmodule.so: undefined symbol: _ZNK9QSGIStyle9classNameEv
-----

¿Es grave doctor?



14
De: rvr Fecha: 2003-05-19 04:23

Uf... Suena mal, gnudista. ¿Qué versión de las Qt tienes instaladas?



15
De: El GNUdista Fecha: 2003-05-22 03:15

Espera que miro..., tengo la libqt3.1.1-14 tex, la actualicé por si era eso, y nada :(



16
De: pj Fecha: 2003-05-28 05:01

GNUdista, es un problema de Mandrake, creo que en PPC y en x86... En el primero seguro :-(

Si buscas en google por "NameEv mandrake" o algo así encontrarás una -muy tediosa- solución (recompilar a mano Qt o PyQt, no estoy seguro y luego no hacer el make install, sino copiar todo a mano) :-)



17
De: rvr Fecha: 2003-05-28 05:30

Hmm... Puede ser que dé problemas el PyQt en PPC. Voy a preguntar.



18
De: Heimy Fecha: 2003-05-28 07:40

El problema de El GNUdista tiene relativamente fácil solución, pero pasa por recompilar. El asunto está en que Debian y Mandrake compilan la mayoría de los estilos (SGI, Windows, Motif, etc) como plugin, y el «configure» de TrollTech no refleja esto correctamente en el fichero qconfig.h; de manera que el «build.py» se confunde y piensa que están dentro, y genera símbolos de más, que luego no están en la lib correspondiente.

GNUdista: Si te fijas, encontrarás un fichero llamado «features» en el mismo directorio donde está el «build.py» que genera el Makefile y todo lo demás. Ese fichero lo genera el build.py la primera vez que lo ejecutas, y luego no lo toca, ya que lo usa como caché, para no tener que repetir determinadas pruebas. Añade lo siguiente a su contenido:

-x Qt_STYLE_CDE
-x Qt_STYLE_MOTIFPLUS
-x Qt_STYLE_MOTIF
-x Qt_STYLE_PLATINUM
-x Qt_STYLE_SGI
-x Qt_STYLE_WINDOWS

y ejecuta de nuevo el build.py. Después de aquí el resto es lo mismo de siempre (make, etc).

Es un problema recurrente en la lista de PyKDE :-)



19
De: El GNUdista Fecha: 2003-05-30 15:24

No he logrado recompilar las PyQt, así que me quedo sin saber como es el blogatex



20
De: teo Fecha: 2003-06-04 07:30

Chicos, ¿habeis mirado el código de la gente que desarrolla para LiveJournal? El de GTK+ es genial, y el de KDE no me compila (para variar :P). Lo de la música (le das a un botoncito y añade de alguna forma a la historia la música que está sonando en tu XMMS).

Me han gustado esos:

- Para KDE, Kluje
- Para GTK+, GNOME, está LogJam



21
De: rvr Fecha: 2003-06-09 14:39

teo: La verdad es que tienen muy buena pinta :)



22
De: Membris Khan Fecha: 2003-06-19 08:08

Este es un programa que hacía mucho tiempo que muchos linuxeros estábamos esperando seguro. Sería más que genial que tuviera soporte para Nucleus, que en su versión 2.0 ha pasado a ser GPL :))

Saludos!!



23
De: Andûr Fecha: 2003-10-20 02:57

Aquí tenéis otro:

http://blogtk.sourceforge.net/

Estoy considerando el crear un blog personal en blogalia (Akin y Eledhwen me dan la tabarra, y algo de envidia además), y el saber que tengo clientes disponibles tanto en UNIX como en Win es una ayuda.



24
De: Josemere Fecha: 2007-02-15 21:36

Alguien podria ser tan amable de explicar como instalar Blogatex 1.0?

Acabo de instalar linux y ando un poco perdido. Es todo tan distinto a Windows. Me he puesto el Ubuntu 6.10



Nombre
Correo-e
URL
Dirección IP: 54.198.200.157 (05afd6ba2e)
Comentario





    


Noticias sobre el desarrollo de Blogalia

Histórico

<Junio 2017
Lu Ma Mi Ju Vi Sa Do
      1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30    
             


Recursos

Proyectos

Otras bitácoras

Canal RDF






 
PostgreSQL

PHP

Python


© 2002-2003 Blogalia.com <blogalia@blogalia.com>


Blogalia